React Flow Versions Save

React Flow | Svelte Flow - Powerful open source libraries for building node-based UIs with React (https://reactflow.dev) or Svelte (https://svelteflow.dev). Ready out-of-the-box and infinitely customizable.

11.11.3

2 weeks ago

11.11.2

3 weeks ago

Patch Changes

11.11.1

1 month ago

Patch Changes

11.11.0

1 month ago

This is hopefully the last release for React Flow 11. It fixes some bugs and adds a deprecation warning for node.parentNode which is now called node.parentId. There are two reasons for this: parentNode poses a name collision with the DOM API and it actually is an id not a node.

Minor Changes

  • #4110 d80b9e7b - deprecate node.parentNode, rename to node.parentId

Patch Changes

11.10.4

3 months ago

Patch Changes

  • #3918 7c8c8574 - fix(edge-marker): use quotes for marker urls to support css vars
  • #3897 7722305c - fix(nodes): re-measure/ re-init correctly

reactflow-11.10.3.tgz

3 months ago

Patch Changes

reactflow-11.10.2.tgz

3 months ago

Patch Changes

11.10.1

6 months ago

Patch Changes

Just a tiny fix for Typescript users who want to use the new screenToFlowPosition and flowToScreenPosition function of useReactFlow.

11.10.0

6 months ago

Upcoming v12

We want to make the migration for v12 as smooth as possible. That's why we added deprecation warnings for the following util functions:

Deprecations / Renamings

Rename useReactFlow.project to useReactFlow.screenToFlowPosition

⚠️ changes: no need to subtract react flow bounds anymore!

before:

const reactFlowBounds = reactFlowWrapper.current.getBoundingClientRect();

const position = reactFlowInstance.project({
  x: event.clientX - reactFlowBounds.left,
  y: event.clientY - reactFlowBounds.top,
});

after:

const position = reactFlowInstance.screenToFlowPosition({
  x: event.clientX,
  y: event.clientY,
});

Rename getTransformForBounds to getViewportForBounds

⚠️ changes: returns { x: number, y: number, zoom: number } instead of [number, number, number].

before:

const [x, y, zoom] = getTransformForBounds(bounds, width, height, 0.5, 2)

after:

const {x, y, zoom} = getViewportForBounds(bounds, width, height, 0.5, 2)

Rename getRectOfNodes to getNodesBounds

no changes, just a renaming.

New features

  • added useReactFlow.flowToScreenPosition

Minor Changes

  • #3597 a114c75b Thanks - chore(utils): add renamed functions and deprecations, add useReactFlow.flowToScreenPosition

Patch Changes

11.9.4

7 months ago

Patch Changes